1
0
Fork 0
mirror of synced 2024-07-24 13:20:22 -04:00
formula-logrotate/.travis.yml
Imran Iqbal 86aed1ebae
feat(yamllint): include for this repo and apply rules throughout
* Semi-automated using `ssf-formula` (v0.5.0)
* Fix errors shown below:

```bash
logrotate-formula$ $(grep "\- yamllint" .travis.yml | sed -e "s:^\s\+-\s\(.*\):\1:")
./logrotate/osmap.yaml
  1:1       warning  missing document start "---"  (document-start)

./logrotate/osfamilymap.yaml
  1:1       warning  missing document start "---"  (document-start)
  7:15      warning  truthy value should be one of [false, true]  (truthy)
  12:14     warning  truthy value should be one of [false, true]  (truthy)
  14:23     warning  truthy value should be one of [false, true]  (truthy)
  16:14     warning  truthy value should be one of [false, true]  (truthy)
  24:14     warning  truthy value should be one of [false, true]  (truthy)

./logrotate/defaults.yaml
  4:1       warning  missing document start "---"  (document-start)
  11:23     warning  truthy value should be one of [false, true]  (truthy)
  13:13     warning  truthy value should be one of [false, true]  (truthy)
  15:13     warning  truthy value should be one of [false, true]  (truthy)
  16:1      error    too many blank lines (1 > 0)  (empty-lines)

pillar.example
  3:1       warning  missing document start "---"  (document-start)
  5:4       warning  missing starting space in comment  (comments)
  6:6       warning  missing starting space in comment  (comments)
  6:5       warning  comment not indented like content  (comments-indentation)
  7:6       warning  missing starting space in comment  (comments)
  9:13      warning  truthy value should be one of [false, true]  (truthy)
  11:13     warning  truthy value should be one of [false, true]  (truthy)
  12:15     warning  truthy value should be one of [false, true]  (truthy)
  13:14     warning  truthy value should be one of [false, true]  (truthy)
  26:12     error    trailing spaces  (trailing-spaces)
  48:12     error    too many spaces after hyphen  (hyphens)
  69:1      error    too many blank lines (1 > 0)  (empty-lines)
```
2019-08-08 10:59:16 +01:00

83 lines
2.5 KiB
YAML

# -*- coding: utf-8 -*-
# vim: ft=yaml
---
stages:
- test
- lint
- name: release
if: branch = master AND type != pull_request
sudo: required
cache: bundler
language: ruby
dist: xenial
services:
- docker
# Make sure the instances listed below match up with
# the `platforms` defined in `kitchen.yml`
env:
matrix:
- INSTANCE: default-debian-9-develop-py3
# - INSTANCE: default-ubuntu-1804-develop-py3
# - INSTANCE: default-centos-7-develop-py3
# - INSTANCE: default-fedora-29-develop-py3
# - INSTANCE: default-opensuse-leap-15-develop-py3
# - INSTANCE: default-debian-9-2019-2-py3
- INSTANCE: default-ubuntu-1804-2019-2-py3
- INSTANCE: default-centos-7-2019-2-py3
# - INSTANCE: default-fedora-29-2019-2-py3
# - INSTANCE: default-opensuse-leap-15-2019-2-py3
# - INSTANCE: default-debian-9-2018-3-py2
# - INSTANCE: default-ubuntu-1604-2018-3-py2
# - INSTANCE: default-centos-7-2018-3-py2
- INSTANCE: default-fedora-29-2018-3-py2
- INSTANCE: default-opensuse-leap-42-2018-3-py2
# - INSTANCE: default-debian-8-2017-7-py2
# - INSTANCE: default-ubuntu-1604-2017-7-py2
- INSTANCE: default-centos-6-2017-7-py2
# - INSTANCE: default-fedora-28-2017-7-py2
# - INSTANCE: default-opensuse-leap-42-2017-7-py2
script:
- bin/kitchen verify ${INSTANCE}
jobs:
include:
# Define the `lint` stage (runs `yamllint` and `commitlint`)
- stage: lint
language: node_js
node_js: lts/*
before_install: skip
script:
# Install and run `yamllint`
- pip install --user yamllint
# yamllint disable-line rule:line-length
- yamllint -s . .yamllint pillar.example
# Install and run `commitlint`
- npm install @commitlint/config-conventional -D
- npm install @commitlint/travis-cli -D
- commitlint-travis
# Define the release stage that runs `semantic-release`
- stage: release
language: node_js
node_js: lts/*
before_install: skip
script:
# Update `AUTHORS.md`
- export MAINTAINER_TOKEN=${GH_TOKEN}
- go get github.com/myii/maintainer
- maintainer contributor
# Install all dependencies required for `semantic-release`
- npm install @semantic-release/changelog@3 -D
- npm install @semantic-release/exec@3 -D
- npm install @semantic-release/git@7 -D
deploy:
provider: script
skip_cleanup: true
script:
# Run `semantic-release`
- npx semantic-release@15